10 novembre 2008

l'ora dello stambecco

Beh, il mio sistema è finalmente passato completamente alla nuova versione della mia distro preferita. Ed è da un bel po' che non parliamo di linux da queste parti, mi sembra il caso di rimediare. Il 30 Ottobre scorso ha fatto capolino sui server di mezzo mondo Ubuntu 8.10. Non cercate qui descrizioni particolarmente tecniche e neppure changelogs. Vi racconto semplicemente la mia esperienza di utente che ha installato su 2 PC ed un notebook il sistema operativo in questione. Ho usato la versione a 64 bit per tutt'e tre le macchine. Ho esordito con il tentativo di installare Kubuntu sul muletto dotato di 2 hard disk: un sata ed un pata. Ho installato kubuntu sul PATA ma non mi è riuscito di correggere il "grub error 15" che è venuto fuori al primo riavvio. Non c'è stato nulla da fare. Piallo tutto ( che bello avere un backup funzionale ) e 20 minuti dopo ero felice configuratore di un bell'ubuntu 8.10 che ha configurato da se tutto, stampante compresa. Poi è stato il turno del mio desktp personale. Ho riprovato con Kubuntu e stavolta niente grub error 15. Tutto a meraviglia. Il magico KDE 4.1 splende sul mio lcd. Installo i drivers proprietari e vado ad impostare il doppio monitor con un bel sudo nvidia-settings. Come per magia lo schermo si estende sul secondo LCD.... vado per salvare la configurazione ma ho un errore di segmentation fault. Anche qui le provo tutte finchè me ne vado a nanna. Il giorno dopo, di cattivo umore, mi sfogo piallando anche il desktop e ripiego sul fido GNOME... CD alternate nel lettore e... sorpresa ( seccante ma non amara ): l'installer dell'alternate è lentissimo: i dialoghi compaiono con lentezza esasperante, come se stessi usando un Pentium 2.... Invece, tra un dialogo e l'altro, tutto corre liscio con la velocità che è lecito attendersi da un Q6600 con 4GB RAM. Terminata l'installazione tutto sembra liscio e scattante, salvo un particolare: manca l'audio. La mia povera audigy2 si sarà forse rotta? Riavvio con Windows e... tutto ok! Mi informo, mando al diavolo pulse audio e ritorno al fido ALSA e tutto torna a posto. E' il momento del notebook, un HP DV 9044EA con 2 Hard Disk. Il boot loader di windows vista non va molto d'accordo con Grub e l'ultima volta che ho provato un dual boot le cose non mi sono andate troppo bene. C'è da aggiungere che il muletto ha solo ubuntu ed il mio desktop non ha un vero dual boot dato che i due sistemi operativi coesistono ignorandosi a vicenda: sono io a scegliere manualmente da quale Hard Disk far partire il PC in fase di boot... Quindi, al dual boot sono piuttosto allergico!Ma ho scoeprto WUBI che consente di impostare il dual boot in maniera sicura e reversibile: ossia, è possibile disinstallare tutta la partizione dedicata ad ubuntu e ripristinare le condizioni iniziali semplicemente da Pannello di Controllo di Windows. Visitate il sito e leggetevi un po' di documentazione. Mi sento di suggerire anche ad un utente relativamente inesperto questo metodo che permette di installare Linux in sicurezza e senza patemi. Ho deciso ( lo so, sono capa tosta ) di riprovare con Kubuntu e stavolta sono stato premiato. Funziona discretamente. Per ora ho individuato 3 problemi: non rileva la webcam integrata, non funziona la condivisione delle cartelle ( ma la rete funziona ) e Kopete invia continuamente segnalazioni di crash anche se tutto funziona...
Insomma, ho aggiornato tutto, venendo meno alla seconda regola del sys admin ( se funziona non toccarlo ) e sono soddisfatto soprattutto del mio notebook con kde, di cui, ultimamente, avevo un po' perso le tracce. Spero di recuperare il tempo perduto.
In definitiva sono comunque soddisfatto della nuova release di Ubuntu, ma avrei gradito OpenOffice 3.0 incluso di default ed un maggior controllo sulla condivisione di files e cartelle.
E voi che aspettate?